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Introduction 
Technical Support 

 

Welcome to the instructional manual for the Warehousing module within the Eagle Business 
Management System (EBMS).  Eagle Solutions is pleased to provide you with instructions and 
tips regarding the Windows version of EBMS.  In the sections following, explanations and 
examples of the available features in the Eagle Business Management System will be explained 
for optimal use of the System.  If you need to reach our staff for further help, contact us using the 
information below: 
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(717) 442-3247 x2 

(717)-442-1096 fax 
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Overview 

The Multiple-Warehouse module of EBMS is an inventory enhancement feature that allows a 
single inventory item to be purchased, stored, and sold from multiple locations.  This inventory 
feature allows a company to track inventory counts within multiple stores or warehouses as well 
as maintaining a sales and purchase history for each location.  Multiple warehouses may identify 
actual warehouses, store locations or service vehicles.  The flexibility of this module can be used 
to associate warehouses with departments, cost centers or company divisions. 

The Multiple Warehouse module is an optional feature that can be added to the standard or 
deluxe versions of Eagle Business Management System. 

The following types of companies benefit from this feature: 

• Retail stores with multiple sales locations. 

• Distributors or wholesalers with warehouses in different locations. 

• Service companies with multiple service trucks that carry inventory on the vehicle. 

A warehouse is often associated with a department or profit center.  This relationship can be 
setup as one of the following options: 

1) Each warehouse is directly related to a single department.  

For example:  

• Warehouse A is associated with department 010; 

• Warehouse B is associated with department 020; 

• Warehouse C is associated with department 030. 

This option allows both the warehouse and department to be set within an invoice using a 
single entry.  The revenue from a sale of an inventory item would be posted to department 
010 if the item were sold from warehouse A, but would be posted to department 020 if the 
same item was sold from warehouse B.  This method is useful if a department identifies a 
store location or company division.  Review the Creating New Warehouses > Associating 
each Warehouse with a single Company Division or Department section for setup details. 

2) This option should be used if a warehouse affects the department setting, but many 
departments exist within a warehouse. 

For example, a hardware store with multiple locations contains multiple departments within 
each location: 

• Store 1 = Warehouse A 

Department 110 – Hardware Department 

Department 120 – Paint Department 

Department 130 – Electrical Department 

• Store 2 = Warehouse B 

Department 210 – Hardware Department 
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Department 220 – Paint Department 

Department 230 – Electrical Department 

Department 240 – Plumbing supplies Department 

• Store 3 = Warehouse C 

Department 310 – Hardware Department 

Department 320 – Paint Department 

Department 340 - Plumbing supplies Department 

Departments are identified based on a combination of the warehouse or location and the 
inventory item. Review the Creating New Warehouses > Associating Multiple Departments to 
Each Inventory Item section below for setup details. 

3) This option applies when the department is associated with the inventory item or product 
and is not affected by the warehouse at all.  Since the warehouse has no affect on the 
department, the department is set within the advanced tab of each inventory item.   It is 
recommended that this option should be used if EBMS is setup with no departments or 
profit centers. 

• Location 1 = Warehouse A 

Department 010 – Hardware Department 

Department 020 – Paint Department 

Department 030 – Electrical Department 

• Location 2 = Warehouse B 

Department 010 – Hardware Department 

Department 020 – Paint Department 

Department 030 – Electrical Department 

Department 040 – Plumbing supplies Department 

• Location 3 = Warehouse C 

Department 010 – Hardware Department 

Department 020 – Paint Department 

Department 040 – Plumbing supplies Department 

Notice that the departments are the same no matter where the inventory item is located.  This 
method is also the most popular when warehouse settings identify service trucks or other smaller 
inventory locations.  Review the Creating New Warehouses > Associating a Single Department to 
an Inventory Item section for setup details. 
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Creating New Warehouses 
Associating each Warehouse with a Single 
Company Division and Department 

This section explains the necessary settings required to associate each warehouse directly with a 
single department. 

The Set Department in Invoice option within General Ledger > Options > Settings must be 

enabled before a warehouse can be associated with a single company division or location. 

 

Review the General Ledger > Departments and Profit Centers > Using a Department as a 
Company Division or Location section for details on this general ledger option. 

All company divisions or locations are to be entered within the department window before 
proceeding.  (Review General Ledger > Departments and Profit Centers section for instructions 
on how to enter departments.) 

1) Go to Inventory > Options > Warehouses tab to open the following options dialog: 
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2) The Set the warehouse from the department option is enabled and can not be changed 

since the general ledger option has been turned ON.  

3) Enable the Default the Transfer quantity to equal the Quantity amount option unless the 
user enters the products in the inventory transfer list before the transfer step is processed.   
This option should be enabled in normal situations. 

4) Disable the Create purchase and variance entries when transferring items option in a 
normal process.   Review the Generate Purchase and Variance Transactions for 
Warehouse Transfers Option section for more details. 

5) The Set consumed items warehouse to equal finished goods warehouse option is used 
within the manufacturing window.  Review the Manufacturing > Using Multiple Warehouses 
section within the manufacturing documentation. 

6) The Next Warehouse Transfer number is a sequential number used in the Warehouse 
Transfer window.  (Review Managing Inventory within a Warehouse > Transferring 
Inventory between Warehouses section for details on the Warehouse Transfer window.) 
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7) The Default Purchase Warehouse and the Default Sales Warehouse can be ignored 
since the default warehouse within both invoice windows is set based on the department 
rather than these settings. 

8) Click on the New button to add a new warehouse. 

 

9) Enter a new Warehouse ID and its associated Department.  Click on the lookup button to 
view all available departments.  Each Warehouse must have a unique Department 
associated with it.  Click OK to create a new warehouse.  Repeat this step for each new 

warehouse. 

Click OK to save option settings. 

The Warehouse cannot be set within the expense or sales invoices.   

 

The Warehouse column within the sales invoice cannot be changed directly by the user.   The 
Department setting located on the invoice heading will change the Warehouse column.   Any 
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inventory that is sold from a different warehouse must be transferred to the invoice’s Department 
using the Warehouse Transfer window.   The user should hide the Warehouse column of the 
sales invoice since these settings are always the same and cannot be changed.   Review 
Managing Inventory within a Warehouse > Transferring Inventory between Warehouses section 
for details. 
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Associating Multiple Departments for each 
Inventory Item 

This section describes the settings required to configure EBMS to allow many departments within 
a warehouse. 

 

1. Go to Inventory > Options > Warehouses tab to open the following window: 

 

2. The Set the warehouse from the department option must be disabled and the Set 
G/L Accounts per Warehouse must be enabled.   

3. Enable the Default the Transfer quantity to equal the Quantity amount option 
unless the user enters the products in the inventory transfer list before the transfer 
step is processed.   This option should be enabled in normal situations. 

4. Disable the Create purchase and variance entries when transferring items 
option in a normal process.   Review the Generate Purchase and Variance 
Transactions for Warehouse Transfers Option section for more details. 



Multiple Warehouses 

10 

5. The Set consumed items warehouse to equal finished goods warehouse 
option is used within the manufacturing window.  Review the Manufacturing > Using 
Multiple Warehouses section within the manufacturing documentation. 

6. The Next Warehouse Transfer number is a sequential number used in the 
Warehouse Transfer window.  Review the Managing Inventory within a Warehouse 
> Transferring Inventory between Warehouses section for details on the Warehouse 
Transfer window. 

7. Click on the New button to add a new warehouse. 

 

Enter a Warehouse ID code and click the OK button. 

8. Enter the Default Purchase Warehouse.  The expense invoice and Inventory > 
Warehouse Transfer windows will default to this setting.  Set the Default Sales 
Warehouse that will be used in the sales invoice.  These defaults are user-defined 

so that each user may select their individual defaults.   

9. Review the Manufacturing > Using Multiple Warehouses section within the 
manufacturing documentation for details on the Default Consumed Items 
Warehouse setting. 

 Click OK to save option settings. 

10. The general ledger accounts are associated with each warehouse within the 
inventory item.  Open the Advanced tab of an inventory item as shown below: 
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11. The general ledger settings must be set for each warehouse.   Change the 
Warehouse setting from the All option to a warehouse option.   The general ledger 
codes can be set for the selected department as shown below: 
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Review the Inventory > Inventory Items > Changing Inventory Defaults section of the 
main manual for details regarding the advanced tab settings. 

Use the Edit Defaults feature and filter down department values to globally change the 
department setting for each warehouse.  Review EBMS Features > Changing Defaults, 
Filtering Down Data and Globally Changing Data section of the main manual for details. 
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Associating a Single Department to an 
Inventory Item 

This section describes the option settings when the warehouse has no relation to a department.  
This option should not be used if EBMS is setup with departments or profit centers   Since the 
warehouse has no affect on the department, the department is set within the advanced tab of 
each inventory item.   

1) Go to Inventory > Options > Warehouses tab to open the following window: 

 

2) Both the Set the warehouse from the department and the Set G/L Accounts per 
Warehouse options must be disabled.  

3) Enable the Default the Transfer quantity to equal the Quantity amount option unless the 
user enters the products in the inventory transfer list before the transfer step is processed.   
This option should be enabled in normal situations. 

4) The Create purchase and variance entries when transferring items option is disabled 
and does not apply in this situation.   
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5) The Set consumed items warehouse to equal finished goods warehouse option is used 
within the manufacturing window.  Review the Manufacturing > Using Multiple Warehouses 
section within the manufacturing documentation. 

6) The Next Warehouse Transfer number is a sequential number used in the Warehouse 
Transfer window.  Review the Managing Inventory within a Warehouse > Transferring 
Inventory between Warehouses section for details on the Warehouse Transfer window. 

7) Click on the New button to add a new warehouse. 

 

• Enter a new Warehouse id and click OK.  Repeat this step for each new warehouse. 

8) Enter the Default Purchase Warehouse.  The expense invoice and Inventory > 
Warehouse Transfer windows will default to this setting.  Set the Default Sales 
Warehouse that will be used within the sales invoice.  These defaults are user selected so 
that each user may set their individual defaults.  Click the OK button. 

The warehouse setting must be set within a sales or expense invoice.  Review the Using 
Multiple Warehouses section for details on setting the warehouse options in various windows. 
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Managing the Inventory on a Service Vehicle 
using the Warehouse Module 

The Warehouse module of EBMS can be useful when managing inventory on multiple service 
vehicles.  Managing and billing inventory properly within the service industry can become a 
daunting task without proper tools to manage parts usage.  Many service companies lose large 
amounts of inventory because inventory is not properly billed or recorded.  Managing inventory 
within service trucks requires the following four steps: 

Setup warehouses within the EBMS software. 

1) Select the Warehouses tab within Inventory > Options to open the following 

dialog: 

 

2) Both the Set the warehouse from the department and the Set G/L Accounts per 
Warehouse options should be disabled.  

3) The Next Warehouse Transfer number is a sequential number used in the 
Warehouse Transfer window.  
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4) Set the Default Purchase Warehouse and the Default Sales Warehouse to the 
main warehouse setting.  This will cause the purchase, sales and transfer entry 
windows to default to the main Warehouse.  Click OK to save the warehouse 
options. 

A service truck is identified as another warehouse within EBMS.  Each truck should 
be entered as a separate warehouse so the inventory can be kept separate between 
the trucks and the main warehouse.  Click on the New button to add a new 

warehouse or service truck. 

 

5) Enter the new Warehouse (service truck) ID and click OK.  Repeat this step for 
each new vehicle or warehouse. 

Inventory parts can be billed from service trucks using a few different processes.     

• Inventory pulled from the general warehouse for a specific job can be entered into the 
sales order at the time the parts are loaded on the truck.  These parts should be billed 
from the general warehouse. 

• Inventory pulled from the truck’s stock inventory can be billed using 2 different options: 

o If the parts that were used from the truck’s inventory are immediately 
restocked, the parts could be billed from the general warehouse.     This 
method saves some data entry steps, but it is very important that a procedure 
is implemented if the parts cannot be immediately restocked on the service 
truck.   This would require the user to do an inventory transfer from the truck to 
the general warehouse or to change the warehouse setting on the sales 
invoice to maintain proper inventory on the truck. 

o The 2
nd
 option is to change the warehouse setting within the sales order to the 

truck’s ID.   An inventory transfer will need to be made for all the items that are 
used to restock the truck. 

Recording the inventory items as they are transferred from a warehouse to a service 
vehicle: 

 
Inventory must be counted and transferred whenever inventory is taken from the 
warehouse to a service truck.  Go to the Inventory > Warehouse Transfer window to 

record any inventory that is used to stock the service truck from the main warehouse.  
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The From Warehouse should be set to the main warehouse and the To Warehouse 
should be set to the service truck being stocked.  List all the inventory that is being 
transferred from the warehouse to the service truck.  (Review the Transferring Inventory 
between Warehouses section for more details on the Warehouse Transfer window.) 

Deducting inventory from the correct vehicle when billing the customer: 

The Warehouse setting within the sales invoice must be properly set when selling 
inventory from a service truck.  Go to Sales > Invoices and S.O.s to invoice a customer: 

 

The Warehouse setting, located on the heading of the invoice, should be set to identify 
the source of the majority of the inventory being sold.  The Warehouse column is the 
setting for individual detail lines that can be changed to reflect a different warehouse or 
service truck.  This will cause the inventory to be deducted from a different source, such 
as the main warehouse or another service truck.  (See the Selling Inventory from a 
Warehouse section for more details on invoicing the customer from different 
warehouses.) 
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Using Multiple Warehouses 
Managing Inventory within a Warehouse 

EBMS records the inventory counts and history for every inventory item within each warehouse.   
The count detail can be viewed from the Count tab and the history within the year tabs.   

Select Inventory > Inventory Items from the main menu and select an inventory item.  Click on 
the Count tab as shown below: 

 

The Warehouse setting on the top of the dialog window affects the Advanced and Count tabs 
as well as the yearly history tabs; it does not affect the other tabs.  Set the Warehouse option to 
All to view the total inventory count values for all the warehouses combined, or select a specific 
Warehouse to view the counts within the selected Warehouse. 

Click on any history year tab and note that the purchase and sales history is maintained for each 
warehouse. 
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The drill-down feature is available for the count and history tabs when the Warehouse is set to 
All or when a specific warehouse is selected. 
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Purchasing Inventory for a Warehouse 

Inventory purchasing and management can differ dramatically between different companies.  
Some of the options are diagramed below: 

• Some may opt to ship all purchased inventories to the main warehouse and then 
distribute inventory to other locations.   

 

• Other companies may purchase and ship directly to individual warehouses.  The 
Multiple Warehouse module of EBMS accommodates either one or a combination of 
the two methods. 

 

The following sections explain the means of purchasing for specific warehouses.  A good 
knowledge of the inventory purchasing window, purchase orders, and expense invoices is 
recommended before proceeding with this section.  Review the Inventory > Inventory Purchasing, 
Expenses > Purchase Orders, and Expenses > Invoices sections of the main manual for general 
instructions on purchasing inventory. 
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Purchasing Inventory using the Inventory 
Purchasing Window 

Select the Inventory Purchasing option from the main Inventory menu to open a sub-menu 
listing the available warehouses. 

 

Select the All Warehouses selection on the menu to purchase inventory based on the stock of all 
warehouses.  This option is useful if the purchasing is based on the stock of all warehouses and if 
all inventories are shipped to the same warehouse.    The user selected a single warehouse – 
General in the following example:  
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Note that the title bar identifies the selected warehouse.  All the values such as Count, Purchase 
Orders, Sales Orders and On Hand will reflect the values for the selected warehouse rather 
than the values for the entire company.  The ordering amount such as Minimum Inventory, 
Maximum Inventory and Order Amount is also based on the values entered within each 
warehouse.  Note that the Order Amount can be within the Count tab of an inventory item with 
the warehouse set to ALL and this value will be copied to all warehouses that do not have a 

value. 

The Order Quantity value is unique for each warehouse setting, including the All Warehouses 
option and will not be lost or changed if another warehouse is selected.  The Order Quantity 
entered for a specific warehouse does not affect the Order Quantity when the All Warehouses 

option is selected.   

A purchase order process is not dependent on the warehouse setting.  (Review the Inventory > 
Inventory Purchasing section for more details on the standard purchasing window and its features 
and processes.) 

To populate inventory purchasing data you must click the Find (F5) button after every 

time a change is made in the window heading. 
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Creating a Purchase Order for a Warehouse  

Go to Expenses > Invoices and P.O.s to open the purchase order window as shown below: 

 

All detail lines of a purchase order that contain inventory items must contain a Warehouse 
setting.  The Warehouse has no affect on the expense invoice if an inventory Item ID is not used.   

EXAMPLE:  The Warehouse setting is not required when entering an electrical bill since no 
inventory is being processed.  Miscellaneous expenses are not posted to a department based on 
the warehouse setting.  Non-inventory expenses should be allocated to a particular department or 
cost center based on the general ledger account rather than the warehouse setting. 

The Warehouse setting will default to the Default Warehouse setting found in Inventory > Options 
> Warehouses tab.  The Warehouse cannot be changed if the General Ledger > Options > 
Settings > Set Department in Invoice option is enabled.  Review the Associating each Warehouse 
with a single Company Division and Department section for more details if the Warehouse cannot 
be changed. 

Create multiple detail lines for the same item if the purchases are distributed to multiple 
warehouses.   See the garden rake example shown above. 
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Transferring Inventory between Warehouses 

The Warehouse Transfer window is used to transfer inventory items from one warehouse to 
another.  This feature is needed if an item is purchased at one warehouse and sold from a 
different warehouse.  A warehouse transfer ticket should be created and processed whenever 
items are moved from one warehouse to another in order to maintain accurate inventory counts.  
Complete the following steps to transfer inventory from one location (warehouse) to another: 

1) Go to Inventory > Warehouse Transfer to open the following window: 

 

2) The Ticket Id is used to identify the specific transfer.  Hit the <Tab> key to use the Next 
Warehouse Transfer number.  The number increments each time it is displaced and 
can be changed in the Inventory > Options > Warehouses tab.  The Ticket Id number 
should be manually entered if a transfer ticket is used that contains a preprinted 
number.  

3) Enter the Date when the inventory is being transferred.  This date is used to post 

inventory history and general ledger transactions. 

4) The User entry will default to the user’s log-in name.  This entry can be changed to 

reflect the user that was responsible for the inventory transfer. 

5) The From Warehouse should be set to the location where the inventory transfer 
originated.  This setting will default to the Default Purchase Warehouse within 
Inventory > Options > Warehouses. 

6) The To Warehouse is the destination of the inventory items and will default to the 
Default Sales Warehouse.  Go to Inventory > Options > Warehouses to edit the list 
of available warehouses or to change the Default Sales Warehouse. 

Complete the following steps for each detail line: 

a) Enter the Quantity of inventory items to be transferred to a new warehouse.  The 
Quantity amount will be recorded within the S.O. Ordered amount of the inventory 

item’s Count tab in a similar way as the ordered amount within the sales order. 
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b) Enter the quantity that was Transferred.  This quantity should be zero if the 
inventory needs to be reserved but is not being transferred at this time.  This will 
cause the items to be reserved but will not affect the net count of the item.  See the 
Inventory > Inventory Item > Count item to view these counts.  The Transferred 
quantity must equal the Quantity column before the batch can be transferred. Set 
the Inventory > Options > Warehouse tab > Default Transferred Quantity to 
Equal the Quantity Amount switch ON to automatically copy the Quantity 
amounts to the Transferred amount.  

c) Enter the inventory Item that you wish to transfer.  This inventory item must be 
classified as Track Count, Registered Whole Goods or Special Orders.  The 
Description and Cost fields will automatically be populated from the information 
entered in Inventory > Inventory Items window. 

d) The Unit of Measure field is an optional field that identifies the unit of measure 
being used for this inventory item.  (See the Unit of Measure section for more 
details.)  If you never use multiple units of measure for any inventory items, this field 
can be removed from the manufacturing window by right clicking on any of the 
column titles and toggling the Measure column off.  

e) The Cost is used to determine the value of the inventory being transferred.  If the 
system is set to process perpetual inventory, the Cost will be calculated on a FIFO 
or LIFO method; otherwise the last cost is used.  Go to Inventory > Options > 
General to view the current Inventory Method setting.  

 Repeat the steps listed above for each inventory item that is being transferred. 

7) Select Process > Process to transfer the inventory from one warehouse to another.  
The following dialog will appear if the Transfer quantities do not match the Quantity 

column values:   

 

Select Yes to copy Quantity values to the Transfer column and continue the transfer process. 

The following transactions are created when an inventory transfer is processed: 

Standard Transfer Transactions     Debit / Credit 

The inventory asset is debited the value of each item Debit 

The inventory asset is debited the negative value of each item Debit (negative) 

The inventory asset account may differ for the same 
item if the Set G/L Accounts per Warehouse option 
is enabled.   This option is found in the Inventory > 
Options > Warehouse tab. 
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No inventory transactions are created for the purchase and variance 
accounts unless the Create purchase and variance entries when 
transferring items option is enabled.   Review the Generate 
Purchase and Variance Transactions for Warehouse Transfers 
Option section for more details on this option.    Review the Inventory 
> Tracking Inventory Counts > Inventory Variance within the main 
documentation for more details on the variance account.   

 

 

 
 

Select File > Copy to make a duplicate of a ticket.  This function can save time when entering 
similar tickets. 

Select File > Save from the transfer window menu to save the transfer information without 
processing the transfer.  

Click on the File > Open from the transfer menu to open an existing transfer ticket. 
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Selecting Process > Unprocess from the Transfer menu can void an inventory transfer. 
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Generate Purchase and Variance 
Transactions for Warehouse Transfers 
Option 

This option is important when processing inventory transfers from one warehouse to another.  Go 
to Inventory > Options > Warehouse tab to view or change this option as shown below: 

 

• A pair of cost-of-sales Transactions is created each time inventory is purchased using an 
expense invoice.  Review the Inventory > Tracking Inventory Costs > Inventory Variance 
section of the main manual for details on the cost-of-sales Transactions. 

• The Generate Purchase and Variance Transactions for Warehouse Transfers option 
should be turned ON only if the general ledger accounts and departments for each 
warehouse are not the same and the purchase values are desired for each warehouse.  
These transactions are not necessary to create accurate cost-of-sales totals for each 
warehouse or division. 

If this option is turned OFF: 
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Only inventory general ledger asset transactions are created to identify the transfer within 
the inventory item’s history.  No cost-of-sales transactions are created.  Review the 
Transferring Inventory between Warehouses section for more details on the standard 
transactions.   

If this option is turned On: 

The purchase values will be debited to the purchase general ledger account for the new 
warehouse and credited to the G/L account for the From Warehouse.  The offsetting 
inventory variance transactions will be created for each warehouse as well.  Inventory 
general-ledger asset transactions are created do matter how this option is set.  Review 
the Inventory >Tracking Inventory Counts > Inventory Variance section within the main 
EBMS documentation for more details on the variance general ledger transactions. 
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Selling Inventory from a Warehouse 

The warehouse must be selected within a sales invoice to identify the source of inventory items 
that are being sold.   

 

The Warehouse field, located on the heading of the invoice, is copied into the Warehouse 
column of each invoice detail line.  The Warehouse column can be hidden if all inventories 
contained within the invoice are sold from the same warehouse.  Review the EBMS Features > 
Column Appearance section for details on the required steps to hide invoice columns. 

A single line of inventory on a sales invoice can be sold from a different warehouse than the 
remainder of the invoice.  This flexibility can be useful to invoice for inventory sold from different 
warehouses.  The warehouse from which the inventory was sold will not be credited (recorded in 
inventory sales history) if the inventory is sold from the original warehouse instead of being 
transferred to the selling warehouse.   

The Warehouse setting is not needed in the invoice details lines that do not contain inventory 

item codes.   

The Warehouse cannot be changed if the General Ledger > Options > Settings > Set Department 
in Invoice option is enabled.  Review the Associating each Warehouse with a Single Company 
Division and Department section for more details if the Warehouse cannot be changed. 
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